Purpose
The purpose of this exercise is to illustrate watershed and stream network delineation based on digital elevation models using the Hydrology tools in the ArcGIS Geoprocessing toolbox. In this exercise, you will perform drainage analysis on a terrain model for the San Marcos Basin. The Hydrology tools are used to derive several data sets that collectively describe the drainage patterns of the basin. Geoprocessing analysis is performed to recondition the digital elevation model and generate data on flow direction, flow accumulation, streams, stream segments, and watersheds. These data are then be used to develop a vector representation of catchments and drainage lines from selected points that can then be used in network analysis. This exercise shows how detailed information on the connectivity of the landscape and watersheds can be developed starting from raw digital elevation data, and that this enriched information can be used to compute watershed attributes commonly used in hydrologic and water resources analyses.

Learning objectives
- Identify and properly execute the geoprocessing tools involved in DEM reconditioning.
- Describe and quantitatively interpret the results from DEM reconditioning as a special case of quantitative raster analysis.
- Construct profiles using 3D Analyst.
- Create and edit feature classes.
- Identify and properly execute the sequence of Hydrology tools required to delineate streams, catchments and watersheds from a DEM.
- Evaluate and interpret drainage area, stream length and stream order properties from Terrain Analysis results.
- Develop a Geometric Network representation of the stream network from the products of terrain analysis.
- Use Network Analysis to select connected catchments and determine their properties.
- Do an online watershed delineation.

Computer and Data Requirements
To carry out this exercise, you need to have a computer which runs ArcGIS 10.1 and includes the Spatial Analyst and 3D Analyst extensions. The data are provided in the accompanying zip file, Ex4Data.zip available at [http://www.neng.usu.edu/dtarb/giswr/2012/Ex4Data.zip](http://www.neng.usu.edu/dtarb/giswr/2012/Ex4Data.zip). The data files used in the exercise consist of a DEM grid for the San Marcos Basin in Texas from the National Elevation Dataset and stream and watershed data from the National Hydrography Dataset NHDPlus. If you want to do similar
work in a different location you will need to download this data from these data sources. URL's for these and other data sources were provided in Lecture 4.

Data description:
Ex4Data.zip should be unzipped and saved in a folder where you will do your work. In this exercise the folder C:\Users\dtarb\Scratch\Ex4 has been used. The unzipped contents of Ex4Data.zip are illustrated below:

![Folder Contents](image)

The geodatabase SanMarcos.gdb contains the following data:

- **INFO**
- **SanMarcos.gdb**

Raster analyses such as watershed and stream network delineation are best performed in a consistent projected spatial reference system (or projection). This is because calculation of slope, length and area are involved and these are best done in linear (not geographic) units consistent with the elevation units. In this exercise to expedite matters for you the data has all been projected into the NAD 1983 Texas Centric Mapping System Albers.prj spatial reference.

In the SanMarcos geodatabase the BasemapAlbers feature dataset contains the four necessary feature classes. Watershed is the set of HUC 12 watersheds within the San Marcos 8 digit HUC 12100203 extracted from the watershed boundary dataset in Exercise 2. Basin is the San Marcos 8 digit HUC 12100203 boundary obtained by dissolving the HUC 12 watersheds. Flowline is a subset of NHDPlus flowlines that cover the San Marcos Basin and surrounding area. USGSgage is a set of USGS stream gages within the San Marcos Basin, similar to what was developed in exercise 2.
There is also a raster smdem that contains the digital elevation model for this region obtained from the National Elevation dataset. This DEM is equivalent to the DEM you worked with in Exercise 3, except that it has a smaller cell size (30 m) appropriate for this analysis and has been projected to the NAD 1983 Texas Centric Mapping System Albers spatial reference being used in this exercise.

The exercise is divided into the following activities that each comprise a sequence of steps

1. DEM Reconditioning
2. Hydrologic Terrain Analysis
3. Network analysis

Before we start
Select Customize → Extensions

Select the Spatial Analyst and 3D analyst extensions. We will be using both of these during the exercise.
DEM Reconditioning

DEM reconditioning is a process of adjusting the DEM so that elevations direct drainage towards the vector information on stream position, which in this case are the blue line stream features obtained from NHDPlus. DEM reconditioning is only suggested when the vector stream information is more reliable than the raster DEM information. This may not be the case here, but reconditioning is done nevertheless to illustrate the process. DEM reconditioning as done here involves a sequence of ArcGIS geoprocessing functions. The strategy is to first convert vector stream features to a raster dataset of grid cells on the streams that has exactly the same dimensions (rows, columns, cell size) as the DEM raster. This exposes you to a number of new geoprocessing tools (Feature to Raster, Greater Than, Reclassify) as well as Environment Settings to control raster cell size, extent and snapping. Then the Euclidean distance from each grid cell to the nearest stream is calculated and a Map Algebra expression used to perform the reconditioning which involved lowering the elevation of all grid cells along the streams by 20 units and grid cells near the streams by a value that tapers from 10 to 0 units based on the distance from 0 out to 500 units. The results are then visualized using 3D Analyst. By doing this you get some experience using the ArcGIS geoprocessing tools to derive new spatial data from the original DEM and vector streams and a small glimpse into the powerful geospatial analytical capability that these functions enable.

1. Feature to Raster.

Open ArcMap. Click on the icon to add data. In the dialog box, navigate to the location of the data; select both the BasemapAlbers feature dataset and smdem raster containing the DEM for the San Marcos and click on the “Add” button. The data provided will be added to the map display.

Click on the search icon on the standard toolbar to open the ArcGIS search window. Enter feature to raster and click on the search magnifying glass. This is a way to find tools if you do not know which toolbox they are in. You have to however know something about their name or a word used in describing their functionality.

Click on the Feature to Raster tool. Select Flowline as the Input features. Use Field COMID (all we need here is some unique number). For output raster designate the name FlowlineRaster in the
SanMarcos.gdb. Note that you can save Rasters in a Geodatabase, which is sometimes a convenient way to keep them organized. Click on the Environments button.

In Environment Settings expand Output Coordinates and select Same as Layer "smdem". Expand Processing Extent and select Extent same as "smdem" and Snap Raster as "smdem". Click OK.

Click OK on Environment Settings. Notice that back on the Feature to Raster tool the output cell size now inherits the value 30 from the snap raster. Click OK on the Feature to Raster tool.
The result is a FlowlineRaster that represents the flowlines as a raster with value corresponding to their COMID. The particular field used was somewhat arbitrary as we really just need a value by which to identify stream grid cells. If you zoom in and adjust the layers displayed you can see that the result is a set of grid cells that have been created from the flow lines. The grid values on these lines are all large integer numbers because that is what the COMID is.

Save your ArcMap document as Ex4.mxd

2. Threshold using Greater Than to obtain stream raster.

To identify whether a grid cell is part of a stream or not, we use the greater than function to obtain a binary (0, 1) raster of stream cells. Locate the Greater Than tool (using the search window) and enter the following input, click OK. This picks out all the cells with COMID’s in them.
The result is a raster with value 1 for stream cells and no data elsewhere.

To use in calculations below, we need 0's not NoData off the streams, so let's reclassify this. Locate the **Reclassify** tool (using the search window) and enter the following input, click OK. (It does not matter which of Reclassify (3D Analyst) or Reclassify (Spatial Analyst) tools you select. They are functionally the same, just associated with different extension licenses)
The result is a raster where NoData values have been replaced by 0's. If you have trouble getting this function to operate correctly, hit the Classify button and open and close this window. This seems to enter a new set of Old Values 0-1 in the Old Values column, first row, and then the function works ok.

3. Distance to streams

Search on distance and open the Euclidean Distance tool. Set Flowline as the input feature and designate distance as the output raster in the SanMarcos.gdb.

Click on Environments and as before set Output Coordinates same as smdem and Processing Extent same as smdem and Snap Raster to smdem.
The result is a grid giving distances to the streams that looks a bit like the inside of an intestine (sorry!).
4. **AGREE Reconditioning with Map Algebra.**

The distance and FlowlineReclas grids contain the information required to do an AGREE like (see Lecture 9 slide 33 and [http://www.ce.utexas.edu/prof/maidment/GISHYDRO/ferdi/research/agree/agree.html](http://www.ce.utexas.edu/prof/maidment/GISHYDRO/ferdi/research/agree/agree.html)) reconditioning of the DEM to burn in the streams. Save your Map document in case of an error, because it is easy to get an error in the next step which requires that the expression below be constructed precisely. Open the Raster Calculator on Map Algebra and construct the following expression (use the keys in the visual keypad to construct this expression and don’t attempt to type it yourself because the spacing between the characters in the expression is important to getting this to work properly).

![Raster Calculator](image)

The output is saved in a raster named **smrecon** (San Marcos reconditioned) in the SanMarcos.gdb. The Map algebra expression is interpreted as follows:

- Subtract 10 at all stream grid cells
- Subtract an amount that tapers from 0.02*500=10 when distance is 0, to 0 when distance is 500 from stream
- Only do taper when distance is less than 500, otherwise this is 0 and nothing is subtracted
Note that the units involved are elevation units which in this case are m. Distance was constructed using map units, which are also m here.

If you have trouble with this step, pick up the required grid from the backup file http://www.caee.utexas.edu/prof/maidment/giswr2012/Ex4/smrecon.zip

5. 3D Analyst
Let's use Raster calculator and 3D Analyst to see what this has produced.

Use raster Calculator to evaluate the following expression

![Raster Calculator](image)

The worm like result shows how the DEM has been altered to reduce values along the streams.
Select **Customize → Toolbars → 3D Analyst** to display the 3D Analyst toolbar.

Set the target layer in the toolbar to **smrecon** and click on the interpolate line button. Draw a line on the map across a stream. Then click on the Create Profile Graph button (under the Point Profile button) to obtain a profile graph.
Repeat the procedure with target layers "smdem" and "diff". It seems that you have to redraw the line each time, but with a bit of fiddling you can illustrate the effect of reconditioning on the DEM.

To turn in:

1. Screen captures that illustrate the effect of DEM Reconditioning. Show the location where you made a cross section as well as the DEM cross sections with and without reconditioning.

Open the attribute table of FlowlineReclas and find the number of grid cells that were mapped as stream cells. Given that the size of each grid cell is 30 m estimate the length of channels in the area.
defined by the smdem grid as this number of cells times 30 m. Actually this is an over estimate because FlowlineReclas approximates the Flowline feature class using a stair step approach. Nevertheless the result is a rough estimate useful for cross checking. Use the total number of grid cells in the FlowlineReclas raster dataset, and grid cell area to estimate the total area and take the ratio to estimate the drainage density (Length of Channels/Total Area).

To turn in:

2. **Number of stream grid cells in FlowlineReclas and estimates of channel length and drainage density.**

Open the Layer Properties of the diff raster and find the average amount of "earth" removed by the reconditioning process. Multiply this by the total area to get the total volume of "earth" removed. The cross section of "earth" removed was a swath 1000 m wide along the streams with triangular cross section (illustrated in a profile graph) going down to 10 m and a spike 30 m wide going down to 20 m. Calculate the area of this cross section and multiply it by the length of channels to get another estimate of the volume of "earth" removed by this reconditioning.

To turn in:

3. **Volumes of earth removed estimated from (a) layer properties of diff and (b) from estimates of channel length and cross section area. Comment on the differences.**

**Hydrologic Terrain Analysis**

This activity will guide you through the initial hydrologic terrain analysis steps of Fill Pits, calculate Flow Direction, and calculate Flow Accumulation (steps 1 to 3). The resulting flow accumulation raster then allows you to identify the contributing area at each grid cell in the domain, a very useful quantity fundamental to much hydrologic analysis. Next an outlet point will be used to define a watershed as all points upstream of the outlet (step 4). Focusing on this watershed streams will be defined using a flow accumulation threshold within this watershed (step 5). Hydrology functions will be used to define separate links (stream segments) and the catchments that drain to them (steps 6 and 7). Next the
streams will be converted into a vector representation (step 8) and more Hydrology toolbox functionality used to evaluate stream order (step 9) and the subwatersheds draining directly to each of the eight stream gauges in the example dataset (step 10). The result is quite a comprehensive set of information about the hydrology of this watershed, all derived from the DEM.

1. **Fill**
This function fills the sinks in a grid. If cells with higher elevation surround a cell, the water is trapped in that cell and cannot flow. The Fill function modifies the elevation value to eliminate these problems.

Select **Spatial Analyst Tools → Hydrology → Fill**. Set the input surface raster as smrecon and output surface raster as fel in SanMarcos.gdb.

![Fill-Spatial Analyst](image)

Press **OK**. Upon successful completion of the process, the “fill” layer is added to the map. This process takes a few minutes.

2. **Flow Direction**
This function computes the flow direction for a given grid. The values in the cells of the flow direction grid indicate the direction of the steepest descent from that cell.

Select **Spatial Analyst Tools → Hydrology → Flow Direction**.

Set the inputs as follows, with output “fdr”.

![Flow Direction-Spatial Analyst](image)

Press **OK**. Upon successful completion of the process, the flow direction grid “fdr” is added to the map.
To turn in:

4. Make a screen capture of the attribute table of fdr and give an interpretation for the values in the Value field using a sketch.

3. Flow Accumulation

This function computes the flow accumulation grid that contains the accumulated number of cells upstream of a cell, for each cell in the input grid.

Select Spatial Analyst Tools → Hydrology → Flow Accumulation.

Set the inputs as follows

Press OK. Upon successful completion of the process, the flow accumulation grid “fac” is added to the map. This process may take several minutes for a large grid, so take a break while it runs! Adjust the symbology of the Flow Accumulation layer “fac” to a classified scale with multiplicatively increasing breaks that you type in, to illustrate the increase of flow accumulation as one descends into the grid flow network. Use 8 classes and hit the “Classify” Button to enable you to select “Manual” method and to type in your class breaks into the window in the lower right hand corner.
After applying this layer symbology you may right click on the "fac" layer and Save As Layer File

The saved Layer File may be imported to retrieve the symbology definition and apply it to other data.

Add the SanMarcos Basin feature class. This shows the outline of the San Marcos basin. Change the symbology so that this is displayed as hollow and zoom in on the outlet in the South East corner. Turn
off unnecessary layers so that you can see the basin feature class on top of the fac layer. Use the identify tool to determine the value of "fac" at the point where the main stream exits the area defined by the San Marcos Basin polygon. This location is indicated in the following figure.

The value obtained represents the drainage area in number of 30 x 30 m grid cells. Calculate the drainage area in km².

Also examine the edges of the San Marcos Basin as represented by the Basin feature class. Note the consistency between this basin boundary and streams as represented by flow accumulation. Notice also how, apart from cutting off a number of meanders, there is generally good agreement between the Flowline feature class and flow accumulation grid. This is a result of the DEM reconditioning that was performed.

To turn in:

5. Report the drainage area of the San Marcos basin in both number of 30 m grid cells and km² as estimated by flow accumulation.

Add the SanMarcos Watershed feature class. This shows the outline of the HUC 12 subwatersheds in the San Marcos basin. Change the symbology so that this is displayed as hollow and zoom in on the outlet in the South East corner. Use the identify tool to find the HU_12_NAME of the subwatershed right at the outlet of the San Marcos Basin.
Use the identify tool to determine the value of "fac" at the point where the main stream enters and exits the area defined by this most downstream subwatershed. Subtract the entering fac value from the exiting fac value to determine the area of this subwatershed. Compare your result to the area reported in the ACRES and Shape_Area attributes of this feature. The Shape_Area attribute was calculated automatically by ArcGIS when this feature class was created and is in the units consistent with the Linear Unit of this feature class, meters in this case, so area is m².

To turn in:

6. **Report the name of the most downstream HUC 12 subwatershed in the San Marcos Basin. Report the area of the most downstream HUC 12 subwatershed determined from flow accumulation, from the ACRES attribute and from Shape_Area. Convert these area values to consistent units. Comment on any differences.**

4. **Isolating our Watershed**

Rather than working with the whole grid, we now want to focus only on the area of the San Marcos Watershed upstream of where flow leaves the Basin feature class. Let's define an outlet point there to help us.

Open Catalog and right click on **SanMarcos\BaseMapAlbers → New → Feature Class**
Set the Name as **Outlet** and Type as **Point Features**. Click Next.

Leave the coordinate system as default (inheriting from the Feature Dataset it is going in to) and click Next. Click Finish at the last screen without changing any of the fields.

Now let's use the Editor to create an outlet point in this feature class. Click on the Editor Toolbar button on the standard toolbar to activate the Editor toolbar.
Click on **Editor ➔ Start Editing**. Zoom right in on the outlet at the bottom right where flow accumulation exits the area. Make sure that the **Outlet** layer is turned on so that it appears in the Create Features list. Using the Create Features button on the Editor Toolbar with **Outlet** clicked carefully place a point at the desired outlet location.

![Editor Toolbar with Outlet layer on](image)

Click **Editor ➔ Stop Editing**. Respond Yes to the Save Edits prompt.

![Editor Toolbar with Stop and Save Editing options](image)

You should now have a new outlet point feature at your designated outlet.

Select **Spatial Analyst Tools ➔ Hydrology ➔ Watershed**. Set the inputs as follows and click OK.
The result should be a Watershed grid that has the value 1 over the area upstream from the outlet point as evaluated from the flow direction field. Be careful to call this result **Wshed** not Watershed because it will get mixed up with the Watershed feature class that you already have in the Geodatabase.

### 5. Stream Definition

Let's define streams based on a flow accumulation threshold within this watershed.

Select **Spatial Analyst Tools → Map Algebra → Raster Calculator** and enter the following expression, using the name **Str** for the output raster.

The result is a raster representing the streams delineated over our watershed.

### 6. Stream Links

This function creates a grid of stream links (or segments) that have a unique identification. Either a link may be a head link, or it may be defined as a link between two junctions. All the cells in a particular link have the same grid code that is specific to that link.
Select **Spatial Analyst Tools → Hydrology → Stream Link.** Set the inputs as follows and click OK.

The result is a grid with unique values for each stream segment or link. Symbolize StrLnk with unique values so you can see how each link has a separate value.

7. **Catchments**

The Watershed function also provides the capability to delineate catchments upstream of discrete links in the stream network.

Select **Spatial Analyst Tools → Hydrology → Watershed.** Set the inputs as follows. Notice that the Input raster pour point data is in this case the StrLnk grid. Click OK.
The result is a Catchments grid where the subcatchment area draining directly to each link is assigned a unique value the same as the link it drains to. This allows a relational association between lines in the StrLnk grid and Area's in the Catchments grid. Symbolize the Catchments grid with unique values so you can see how each catchment has a separate value.

8. Conversion to Vector
Let's convert the raster representation of streams derived from the DEM to a vector representation.

Select Spatial Analyst Tools → Hydrology → Stream to Feature. Set the inputs as follows. Note that I put the output in the BaseMapAlbers feature dataset.
Note here that we uncheck the Simplify polylines option. The simplification can cause streams to "cut corners" that will result in errors when they are later on matched up with values on an underlying stream order grid during the process of determining stream order.

The result is a linear feature class "DrainageLine" that has a unique identifier associated with each link.

Select **Conversion Tools → From Raster → Raster to Polygon**. Set the inputs as follows:

The result is a Polygon Feature Class of the catchments draining to each link. The feature classes DrainageLine and CatchPoly represent the connectivity of flow in this watershed in vector form and will be used later for some Network Analysis, that is enabled by having this data in vector form.
To turn in:

7. Describe (with simple illustrations) the relationship between StrLnk, DrainageLine, Catchments and CatchPoly attribute and grid values. What is the unique identifier in each that allows them to be relationally associated?

9. **Strahler Stream Order**

Run Spatial Analyst Tools → Hydrology → Stream Order with inputs as follows.

![Stream Order tool](image)

The result is a Raster StrahlerOrder that holds Strahler Order values for each grid cell. Let's now associate these with the streams represented by DrainageLine.

Locate the Zonal Statistics as Table (Spatial Analyst) tool and run it with inputs as follows.

![Zonal Statistics as Table tool](image)

The result is a Table "OrderTable" that has zonal statistics from the StrahlerOrder grid corresponding to each link in the StrLnk grid. Open the DrainageLine attribute table. Select Table Options → Add Field. Specify the name StrahlerOrder and leave other properties at their default. (Strahler Orders are small integer numbers that should fit in a Short Integer data type)
Select Table Options → Joins and Relates → Join, then specify the Join data as follows:

- Select the field in this layer that the join will be based on:
  - grid_code

- Choose the table to join to this layer, or load the table from disk:
  - OrderTable

- Choose the field in the table to base the join on:
  - grid_code

Respond No to the prompt about indexing.
The DrainageLine table now displays many more columns because it has included all the columns from OrderTable. Since the Strahler Order is the same for each link, the fields MIN, MAX, MEAN, MAJORITY, MINORITY, MEDIAN all hold the same value, the stream order and any one of these can be copied into the StrahlerOrder field we just created.

Right Click on the StrahlerOrder field header and select Field Calculator. Click Yes to the warning about working outside an edit session, then double click on the OrderTable.MIN field so that the Field Calculator displays as follows and click OK.

Notice that the StrahlerOrder field is now populated with the minimum OrderTable.MIN values. Remove all Joins from the DrainageLine table.

Symbolize the DrainageLine feature class using Strahler Stream Order for color and line width.
To turn in:

8. A layout showing the stream network and catchments attractively symbolized with scale, title and legend. The symbology should depict the stream order for each stream.

10. Stream Gauge Subwatersheds
It is often necessary to delineate watersheds draining to specific monitoring points on the stream network, such as stream gages. Let's do this. If necessary add the USGSgage feature class. This is a stream gauge feature class similar to that used in previous exercises. Zoom in close to one of the gages. You will see that although close, the gages do not lie exactly on the streams.

Use Spatial Analyst Tools → Hydrology → Snap Pour Point with the following input

![Snap Pour Point dialog box]
This results in a raster of pour points close to each gage but on the stream as defined by flow accumulation.

Use **Spatial Analyst Tools → Hydrology → Watershed** with the following input:

This results in subwatersheds delineated to each stream gage. These may be used with zonal functions to evaluate properties of the subwatersheds draining to these gauges.

To turn in:
1. Indicate the field in the gages table that is associated with values in the wshedG. Give the area in number of grid cells and km$^2$ of each gauge subwatershed. Add these as appropriate to give the total area draining to each gauge and compare to the DA_SQ_MILE values from the USGS for these gauges.

**Network Analysis**

Some of the real power of GIS comes through its use for Network Analysis. A Geometric Network is an ArcGIS data structure that facilitates the identification of upstream and downstream connectivity. Here we step through the process of creating a geometric network from the vector stream network representation obtained above, and then use it to determine some simple aggregate information.

Zoom in to near the Outlet and select Start Editing on the Editor Tool. Sometimes you encounter a warning that certain layers are not editable. If this happens close and re-open ArcMap. Click on the Edit Tool (red circle below) then click on the outlet point and drag it until it lines up with the DrainageLine Endpoint as shown below. It should snap right on.

Select Stop Editing and Save on the Editor.

Now open the Catalog window and right click on **BaseMapAlbers → New Geometric Network**
Click Next on the New Geometric Network screen. Enter the name **SanMarcosNet**, then click Next.

Select the features **DrainageLine** and **Outlet**. These will be used to create a Geometric Network. Click Next.
At the prompt to Select roles for the network feature class switch the role under Sources and Sinks for Outlet to Yes. This will be used as a Sink for the network. This is a location that receives flow. Click Next.

Do not add any weights at the prompt about weights, just click Next. Click Finish at the summary prompt. The result is a Geometric Network SanMarcosNet that can be used to perform network operations.
Select **Customize → Toolbars → Utility Network Analyst** from the main menu to activate the Utility Network Analyst toolbar.

Click on **Flow → Display Arrows** on the Utility Network Toolbar.

The result is a set of black dots on each network link. These indicate that flow direction for the network is not assigned.

To assign network flow direction the Outlet needs to have a property called AncillaryRole set to be the encoding for Sink.
Open the Editor toolbar and select Start Editing (Click Continue if there is a warning). Use the Editor Edit Tool to select the point at the outlet in the Outlet Feature Class (There is only one point) and select it in the dropdown that appears.

Click on the Attributes button on the Editor Toolbar to open the attributes display panel.

The panel should show that the AncillaryRole for this point is "None". Change it to Sink.

Click on the Set Flow Direction Tool on the Utility Network Analysts toolbar. You must have the network open for Editing when you do this or the Set Flow Direction tool will be grayed out and inoperable.
You should see the black dots switch to arrows indicating that Flow in the network is now set towards the designated Sink at the outlet. This network is now ready for Analysis. Stop Editing, saving edits.

If you have trouble creating the Geometric Network in the preceding instructions, you can pick up a new network geodatabase for this part of the exercise at: http://www.caee.utexas.edu/prof/maidment/giswr2012/Ex4/Ex4Network.zip You can use this network to continue the exercise.

Zoom to the vicinity of one of the USGS stream gauges and place an edge flag near the gauge using the Utility Network Analyst Add Edge Flag Tool.

Set the Trace Task to Trace Upstream and press Solve.

The result is a highlighting of the link that has the edge flag and all links upstream.
Select Analysis ➔ Options

Switch the Results format to Selection. Select Analysis Clear Results and run the trace again.
Now the upstream features are selected. Open the Drainage Line feature class attribute table and show selected records.

Right click on column header **Shape_Length** → **Statistics**
Record the total length and number of stream links upstream of each USGS gauge. Note that there is a small error in these results due to the gauge being part of the way along the flagged link which is included in the calculations. The link could be split to make this analysis more precise but that will not be done here (it would add another 5 pages and few hours to this already long assignment). Switch the Trace Task to **Trace Downstream** and press **Solve** again. Notice how the selected stream links switch to those downstream from the flag. Determine the total length of these links as an estimate of the distance along the rivers from each gauge to the downstream outlet. Join the CatchPoly attribute table to the DrainageLine table. This provides access to the area draining directly to each stream link. Evaluate the total area upstream of each using **Shape_Area ➔ Statistics**. You can also, by placing a flag at an upstream link determine the flow path (and its length) from any distant link to the outlet. Evaluate the length of the longest flow path by choosing a link that appears to have the longest flow path (a bit of trial and error may be necessary). Prepare a layout that illustrates the longest flow path in the San Marcos watershed.
To turn in:

2. A table giving for each USGS gauge the number of upstream stream links, the total length of upstream stream links, the total upstream area, drainage density (total length/total area), number of downstream links along path to outlet, distance to outlet along the streams.

3. A layout illustrating the longest flow path in the San Marcos watershed and giving the length in km.

Watershed Delineation using ArcGIS World Water Online Cloud Processing Functionality

From the ArcToolbox window, right click for the context menu then click Add Toolbox. In the browser dropdown double click GIS Servers (you’re going to add a toolbox from a server).

Double click Add ArcGIS Server.
Take the default of “Use GIS Services” and click Next

Enter the following address as the Server URL:

http://23.20.162.217:6080/arcgis/services
Username = esri_watershed
Password = giswr2012
Click Finish

In the Add Toolbox dialog double click on the service arcgis on 23.20.162.217_6080

Double click on the folder called WorldWatershed

Click on the WorldWatershed GP service icon, then click Open

A new toolbox should be added to your ArcToolbox window called WorldWatershed, which contains a tool called Watershed_nosimp

This tool will perform watershed delineation based upon the NHDPlus version 1 within the continental US using processing at ArcGIS online.

Using this system requires the ESRI World Hydro Basemap. Click the down arrow on the Add Data icon and select Add Data from ArcGIS Online
Search for “world hydro” and click the Add button on World Hydro Reference Overlay (or whichever piece you want. There are separate pieces for streams, waterbodies, and hydrologic units).

Notice how the Basin Feature Class from our work aligns well with the basemap display.
Now open the Watershed_nosimp tool and click on our outlet point to create a WaterShed_Point interactively from the map.

Click OK.
The result should be a watershed delineated by the online tool.

You can open the attribute table for this Watershed to see the attributes that this tool has calculated. This includes elevation, area and slope. The nice part about this tool is that it can be used to delineate a watershed anywhere in the continental US without having to do all the data processing that we just went through in this exercise. Later this online watershed delineation capability will be world-wide.

To turn in:

4. A screen capture that shows the watershed delineated by the online tool.

5. A table comparing the minimum elevation, Maximum elevation and Area determined from the Online tool with values that you obtained from the DEM used in this exercise.

OK. You are done!

Summary of Items to turn in.

1. Screen captures that illustrate the effect of DEM Reconditioning. Show the location where you made a cross section as well as the DEM cross sections with and without reconditioning.

2. Number of stream grid cells in FlowlineReclas and estimates of channel length and drainage density.

3. Volumes of earth removed estimated from (a) layer properties of diff and (b) from estimates of channel length and cross section area. Comment on the differences.
4. Make a screen capture of the attribute table of fdr and give an interpretation for the values in the Value field using a sketch.

5. Report the drainage area of the San Marcos basin in both number of 30 m grid cells and km$^2$ as estimated by flow accumulation.

6. Report the name of the most downstream HUC 12 subwatershed in the San Marcos Basin. Report the area of the most downstream HUC 12 subwatershed determined from flow accumulation, from the ACRES attribute and from Shape_Area. Convert these area values to consistent units. Comment on any differences.

7. Describe (with simple illustrations) the relationship between StrLnk, DrainageLine, Catchments and CatchPoly attribute and grid values. What is the unique identifier in each that allows them to be relationally associated?

8. A layout showing the stream network and catchments attractively symbolized with scale, title and legend. The symbology should depict the stream order for each stream.

9. Indicate the field in the gages table that is associated with values in the wshedG. Give the area in number of grid cells and km$^2$ of each gauge subwatershed. Add these as appropriate to give the total area draining to each gauge and compare to the DA_SQ_MILE values from the USGS for these gauges.

10. A table giving for each USGS gauge the number of upstream stream links, the total length of upstream stream links, the total upstream area, drainage density (total length/total area), number of downstream links along path to outlet, distance to outlet along the streams.

11. A layout illustrating the longest flow path in the San Marcos watershed and giving the length in km.

12. A screen capture that shows the watershed delineated by the online tool.

13. A table comparing the minimum elevation, Maximum elevation and Area determined from the Online tool with values that you obtained from the DEM used in this exercise.